Browse Source

Check for lua and lua5.1 as pkg-config name with autotools

git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@2347 152afb58-edef-0310-8abb-c4023f1b3aa9
svn/tags/lighttpd-1.4.21
Stefan Bühler 13 years ago
parent
commit
376d613953
  1. 6
      configure.in

6
configure.in

@ -418,6 +418,12 @@ if test "$WITH_LUA" != "no"; then
PKG_CHECK_MODULES(LUA, $WITH_LUA >= 5.1, [
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
],[
# for debian based systems
PKG_CHECK_MODULES(LUA, lua5.1 >= 5.1, [
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
])
])
AC_SUBST(LUA_CFLAGS)

Loading…
Cancel
Save